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Creating a Course Web Site 

As an educator or administrator you are always looking for new and exciting ways to communicate 
with students and others in an easy to use, cost effective, and efficient manner. The World Wide 
Web satisfies all these criteria and allows almost instant delivery of information, virtually 
anywhere. You can create a reference page with links and a course calendar, or you can create an 
entire online course. FrontPage 2000 allows you to easily create and maintain Web pages suited 
to your needs without having to know any HTML. 

In this hands-on session, you will learn how to create a course Web site. You will learn how to use 
templates and themes to create your site, make your Web site easy to navigate, , and view activity 
on your site. You will also learn how to add a threaded discussion enabling students to interact 
with each other online. 

Before You Begin 

Microsoft® FrontPage® is a Web site authoring and management program. It has many powerful 
features, yet it is still easy to master. 

FrontPage allows you to create individual Web pages, entire Web sites, or update existing Web 
pages and sites. Some of the functionality is enabled by server extensions, which must be loaded 
on the server where the Web content will be published. FrontPage server extensions are available 
for most popular Web servers. If you want to see the current list see 
www.microsoft.com/frontpage. You can easily test your Web pages by previewing them in your 
favorite browser. When you are ready to publish your creation to a live Web server, simply click the 
Publish button and specify the server you want to use. 
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Touring FrontPage 

Before you start developing your own Web pages, become familiar with the features 
of FrontPage. The following illustration shows the Navigation view:  
 

 

Using Web Templates 

This section describes how to quickly create a class Web site to deliver course 
materials and timelines, and to provide a forum for your students to communicate 
electronically. 

You will use the New FrontPage Web Wizard to create your Web from a template, 
name it, and then choose the server on which you want to store your Web. 

Words to know: 
 
Browser—A program 
that allows you to 
view HTML formatted 
documents (like 
Microsoft® Internet 
Explorer). 
 
HTML—HyperText 
Markup Language. 
The language used to 
format web pages. 
 
Microsoft® 
FrontPage 2000—The 
latest version of 
Microsoft’s Web 
authoring and 
management program 
used to create and 
manage Web sites 
and pages with no 
knowledge of 
programming in 
HTML. Provides 
Seamless integration 
with the Microsoft 
Office family of 
applications. 
 
Microsoft® Internet 
Explorer 5.0—Is the 
latest version of 
Microsoft’s popular 
web browser. It allows 
editing and displaying 
of Web pages and 
collaboration on 
standard office 
documents through 
discussions and 
round tripping. 
 
Threaded 
Discussions—A Web 
page feature that 
allows individuals to 
have a topic based 
discussions 
 
URL—Uniform 
Resource Locator is 
the name and 
location of a file or 
web page. 
 
World Wide Web— 
The collection of 
interconnected 
computers on the 
Internet. 
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The following illustration shows the dialog box you use to create a new Web from a 
Wizard or a template: 

 

To create a Web site with a wizard 

1. Start FrontPage. 

2. On the File menu, click New, and then click Web. 

3. Click Class Web. 

4. Type the address of your Web server in the Specify the location of the 
new Web box, and then click OK. In this workshop, type in 
http://webserver/myclass##. The ## after myclass is the number of 
the machine you are using. Once the web is created, you are in Page 
view. 

5. In the Views bar, select Navigation. 

The organizational structure of your new Web is shown in the Views Pane. 
You can now add your own information to the pages created by the Wizard 
and even create additional pages as necessary. Later in this workshop you 
will learn how to add a Threaded Discussion page to your site. 

You can test your 
Webs on your own 
computer before you 
publish them to a 
Web server. 
However, anything 
that requires server 
functionality will not 
be available. 

 
Class Web is one of 
the templates in the 
themes and 
templates add-on 
pack available for 
download on the 
Microsoft web site. 
Be sure to check the 
FrontPage section of 
the Microsoft web 
site for 
enhancements, 
updates, and 
breaking news 
regarding FrontPage.
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To create a new page 

1. On the File menu, click New, and then click Page. 

2. Right-click on the new page in Navigation view, and then click Rename. 

 

3. Type Survey in the page title box and then press Enter to save your 
changes. 

4. Double-click on Page on the Views bar to change to Page view. 

5. Type in a brief synopsis at the top of the survey that describes to 
perspective respondents the reasons why they should take the time to 
fill out the form. 

Using Themes 

The Class Web template uses a theme, or a standard design for all the pages 
included in your site. Themes make it easy to format the appearance of an entire 
Web site. Themes change the fonts, colors, buttons, and background into a 
single page or site-wide format. Using themes, you won’t have to make 
formatting changes on each individual page. Just choose the theme you want 
from the list to change the entire look of your site. Note that individualized page 
formatting that has been done will be overwritten with the new theme. Therefore, 
the general rule of thumb is to choose a theme first and then modify individual 
pages to suit your needs. If you like, you can choose a different theme to apply to 
your course Web site. 

You can create a 
customized theme for 
your institution using 
the ”modify” button in 
the themes dialogue 
box. 
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To apply a theme 

1. In the Format menu, click Themes. In the Apply Theme to: option 
button, click either Selected page or All pages, based on your 
preference. 

2. Scroll up and down the list of themes in the Sample of Theme list to 
select the individual themes you want to display. Once you have 
selected one, click OK to accept the changes and close the list. 

 

3. If you would like to change the components of a theme, click the Modify 
button and click the area you want to change (Color, Graphics or Text), 
and then make your changes in the resulting dialogs. 

4. Click OK to save your changes to the theme. 

Using Shared Borders for Navigation 

One of the most important considerations in creating a Web site is to make it 
easy to navigate. Users need to be able to find and use the pages in your site 
quickly and easily. If your site is difficult to use, it will not be an effective learning 
tool. 

With FrontPage you can use the structure available in the Navigation view to 
organize your pages. Through this view you can use shared borders to provide 
complete navigation of your site. Simply drag the pages in the Navigation view to 
the appropriate spot in the hierarchy of Web pages and then place navigation 
bars in the appropriate area on a Web page to apply a change to all pages. 

The ease of Web page 
creation is enabled by 
FrontPage Server 
Extensions on the Web 
server. If you do not 
wish to use these 
features, you may 
disable the features 
that require these 
extensions from the 
Options menu. 
 

 
You can create a 
customized theme 
for your institution 
using the “modify” 
button in the themes 
dialogue box. 
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To activate Shared Borders 

1. In Page view, right-click anywhere on the page and select Shared 
Borders. (You already have shared borders on your class Web because 
you are using a theme.) 

2. Click the check boxes for the borders you want to use and select Apply 
to: All pages or Current page, based on your preferences. 

3. Click OK to accept your changes and close the dialog box. 

To add Navigation Bars 

1. Click on the bottom shared borders and from the Insert menu select 
Navigation Bar. The Navigation Bar Properties dialog box opens. 

 
2. Select Child pages under Home. Under Orientation and appearance, 

select Text, and then click OK. As you add new pages to your site, the 
navigation bars will update automatically. 

To automate the use 
of shared borders for 
website navigation, 
make sure to use the 
Navigation view to 
establish an 
organizational chart 
of your web. 
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Using Categories 

Many Web sites use site maps to make it easier for site visitors to find the pages 
they need. The shared borders you created will allow easy navigation of the Web 
site, but they will not provide one click access to all pages within the Web. A site 
map provides an organized set of links to all pages in your Web site. You can 
easily create a site map by using categories. Categories allow you to organize 
individual Web pages into groups, for example, assignments, exams, and 
discussions. Then you can organize the display of links to those pages on a site 
map. Smaller Web sites can accomplish this by using a Table of Contents, but as 
the site grows the Table of Contents will become unwieldy and implementing the 
use of a site map that is organized by categories will become imperative. 

To create categories 

1. In any view except Tasks, right-click on a file in the Folder List, select 
Properties, click the Workgroup tab, and then click Categories. 

2. Type the category you want to create in the New Category box, for 
example, Assignments, and then click Add. Repeat this for each new 
category. (Create categories for Assignments, Exams, Information, and 
Notes.) 

3. Click OK to close the Master Category List and OK a second time to 
close the Properties dialog box. 

To apply categories to pages 

1. In Navigation view, right-click on a page, select Properties from the 
shortcut menu, and then click the Workgroup tab. 

2. Select the check boxes beside the categories you want to assign to the 
page, and then click OK. 

To assign categories to a file in the Folder List, right-click on the file you 
want to assign categories to. Select Properties from the shortcut menu and 
then click the Workgroup tab. Select the check boxes beside the categories 
you want to assign to the page and click OK. 
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To create a Site Map 

1. On the File menu, click New and then click Page. The page will appear 
at the bottom of the Folder List. Type sitemap.htm as the file name. 

2. Right-click on the file, select Properties and type Site Map in the Title 
box and click OK. Drag and drop the file into the top level of the 
organizational chart in Navigation view (the same level as Grades, 
Assignments, and so on). 

3. Double-click on the Site Map page to open it for editing. 

4. Type Assignments: and press Shift+Enter to move the insertion point to 
the next line. 

 
5. From the Insert menu, click Component, and then click Categories. 

Select the Assignments check box and click OK. Press Enter to start a 
blank new line. This displays the pages you assigned to the Assignments 
category in this list. Multiple categories may be selected, allowing one 
page to appear in multiple sections of your site map. 

6. Repeat steps 4 and 5 for each category you want to appear in the site 
map. (Add Exams, Information, Miscellaneous, and Notes.) 



Creating a Course Web Site 
 

 9 

Creating a Threaded Discussion 

Your students might not have the luxury of being in close proximity to each other, 
and even if they are, their time is at a premium. You can facilitate out of class 
discussion by creating a forum on your Wed site for a structured, topic-based 
conversation.  A Threaded Discussion allows Users to enter an online 
conversation at any time and be able to quickly understand the current 
discussion. The Discussion Web Wizard makes it easy to add a threaded 
discussion to your course Web site. 

To create a Threaded Discussion Web 

1. From the File menu, click New, and then click Web. The New dialog box 
appears. 

2. Click Discussion Web Wizard, select the check box for Add to current 
Web, and then click OK. The Discussion Web Wizard opens. 

3. Click Next, and then click Next again. This confirms the main features of 
the discussion (leave the defaults checked). 

4. Enter a title for your discussion. Leave the discussion folder as _disc1, 
and then click Next. 

5. Click Next on the fourth page indicating you want to have only subject 
and comments on a submission form. 

6. Click Next on the fifth page indicating that you want to allow anyone to 
participate in the discussion. The discussion can be restricted if you 
want by selecting Yes. 

7. Select Newest to oldest as the sort order for messages on the sixth 
page, and then click Next. 

8. Make sure to leave No selected on the seventh page and click Next. 

Microsoft Exchange 
Server 5.5 includes a 
FrontPage Discussion 
Wizard enabling you to 
use Exchange Public 
Folders to host your 
discussions giving you 
more control over the 
discussion. 
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9. Select how you want items found in a search to be displayed and click 
Next. 

10. Select Contents beside current article to allow ease of navigation 
within the discussion, and then click Next. (Frames are supported by 
most browsers now so don’t hesitate to use them.) 

11. Click Finish on the last page, but pay attention to the fact that the 
Wizard is giving you the name of the main page in the discussion Web’s 
structure, you will need to place this information into the navigational 
structure of the main Web. The filename of the page will be 
disc1_frm.htm. 

12. Switch to Navigation view and drag and drop disc1_frm.htm into the 
organizational structure at the level directly below the home page. 

13. Right-click the page, click Rename and change the page name to 
Discussion. Press Enter. 

Web Site Management 

You now have a course Web site that will be a very useful resource for your 
students to discuss and access information about your class. You have even 
provided the ability for students to collaborate with peers. Of course you will want 
all of your work to stay usable and current. It is frustrating to navigate through a 
stale Web site filled with links that are no longer valid. You also want to see if 
your Web site is being used. 

You can maintain your Web site through reports that allow you to get a bird’s eye 
view of the health and vitality of your site. Broken hyperlinks, slow pages, stale 
pages, quantity of pictures, and links are available in a report. Hit Counters will 
provide you with the number of visitors to a given page. This allows you to see 
the popularity of specific pages in your site, although most Web sites usually put 
a Hit Counter only on the home page. 

To add a Hit Counter 

1. Double-click the home page in Navigation view to open it for editing. 

2. From the Insert menu, click Component, and then click Hit Counter. 

3. Select the number style you want and click OK. 

4. Type Visitors since and today’s date (for example, Visitors since 
4/10/2000). Save your work. 

To easily edit 
different pages, just 
double click on the 
page you wish to 
change to in the 
Navigation View. 
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To view site statistics 

• From the View menu, click Reports, and then click the report that you want. 
If you want an overview of the entire range of items tracked on your site, 
click Site Summary. 
-or- 
Click Reports on the Views bar to display the last selected report. 

 

For more detailed information about Web site traffic, look into the many 
applications available for Web servers that provide a highly detailed analysis. 
Refer to your Web master for answers to your specific questions. 

 

Getting Help 

You can get help from the Office Assistant or the online Help at any time while you 
are using FrontPage. To open the Office Assistant, click the FrontPage Help button 
on the Standard toolbar. To open the online Help, on the Help menu click Microsoft 
FrontPage Help. If you have an Internet connection, you can also point to Office on 
the Web on the Help menu and choose from several resources that may be of 
interest to you such as Product News, Frequently Asked Questions, and Online 
Support. Don’t forget to go to www.microsoft.com/frontpage for all the latest 
information. 
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Information in this document, including URL and other Internet Web site references, 
is subject to change without notice. Companies, names and data used in examples 
herein are fictitious unless otherwise noted. 

© 1999 Microsoft Corporation. All rights reserved. 
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Classroom materials. Microsoft grants permission for educational institutions and 
Microsoft OEMS and Solution Partners to reproduce these materials for staff 
development purposes (only). Altering materials or reselling materials is strictly 
prohibited. 

Microsoft, BackOffice, FrontPage, Microsoft Internet Explorer, and the Microsoft 
Internet Explorer logo, the Microsoft Office logo, NetMeeting, Outlook, PowerPoint, 
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Windows Start logo are either registered trademarks or trademarks of Microsoft 
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